wiki:s2013/paate/ohjaus3
Last modified 4 years ago Last modified on 2013-09-26 15:15:23

Pääteohjaus 3

Nyt siirrymme ConTextista ja komentoriviltä kääntämisestä Visual Studioon. Vaikka Visual Studio tekee meidän puolesta monia asioita automaattisesti on kuitenkin tärkeää että ymmärrämme mitä "taustalla" tapahtuu, ja siksi olemme tähän asti operoineet ilman graafista käyttöympäristöä.

Visual Studio on IDE, eli Integrated development environment, suomeksi yleensä vain tylsästi ohjelmointiympäristö. Integrated-sana tarkoittaa lyhyesti sanottuna, että samassa paketissa on monta ohjelmaa, yleensä mm. koodieditori, debuggeri (eli virheenjäljittäjä, johon tutustumme tarkemmin ensi viikolla) ja kääntäjä.

(Integroidun) ohjelmointiympäristön käyttämisestä on monia hyötyjä, kuten se, ettemme enää joudu tekemään ohjelman kääntämistä ja kääntämisen jälkeistä suorittamista manuaalisesti. Kuitenkin, jos olisimme suoraan aloittaneet Visual Studiosta, olisi kokonaisuuden ymmärtäminen jäänyt puutteelliseksi.

  1. Käynnistä Visual Studio. Jos et ole aiemmin käynnistänyt Visual Studiota, kysytään käyttöympäristön valintaa. Valitse C# Development Settings ja klikkaa Start Visual Studio. Jos ohjelma kyselee sinulta vielä GhostDoc-asetuksia, voit klikata Skip.
    • Jos kuitenkin vahingossa klikkasit jotain muuta kuin C#:a, niin ei hätää, toimi seuraavasti: 1. Valitse ylhäältä Tools -> Import and Export Settings..., 2. Valitse "Reset all settings", 3. Valitse "Yes, save my current settings" ja paina Next, 4. Valitse haluamasi ympäristö.
  2. Rivinumerot näkyviin (jos eivät jo ole). Tools -> Options -> Text Editor -> C# -> Line numbers. Jos haluat niin voit suurentaa tai pienentää myös fonttia Tools -> Options -> Environments -> Fonts and Colors.
  3. Tehdään Demo 3 tehtävä 4 ja sitä varten ensimmäinen projekti. (Lue myös yksityiskohtaisemmat ohjeet projektin luomiseksi C# wikissä).
    • File -> New -> Project (tai Ctrl + Shift + N)
    • Valitse projektin tyypiksi Visual C# -> Console Application.
    • Anna projektin nimeksi Muunnoksia,
    • Kirjoita tai selaa (Browse) poluksi C:\MyTemp\OMATUNNUS\ohjaukset\ohjaus3 (tai mikä onkaan oma demohakemistosi). HUOM! Suositellaan aina tekemistä ensin paikalliselle levylle, esim. C:\MyTemp\omatunnus\.... Muista siirtää tiedostot lopuksi TÄRKEÄT tiedostot U-asemallesi.
    • Klikkaa Create new directory for solution.
    • Anna solutionin nimeksi demo3.
    • Muuta Solution Explorerissa kooditiedoston Program.cs nimeksi Muunnoksia.cs (Hiiren oikea nimen päällä). Vastaa Yes kun VS kysyy huomioidaanko muutos projektin muissakin tiedostoissa. Nyt luokan nimikin pitäisi olla muuttunut koodissa.
    • Kirjoita luokan dokumentaatiokommentti näppäilemällä luokan esittelyrivin yläpuolelle kolme kauttaviivaa ///. Kirjoita <summary>-tagien väliin selvitys luokan toiminnasta.
    • Kirjoita Main-metodin sisään tehtävässä annetut kaksi koodiriviä, luo tarvittava aliohjelma ja dokumentoi se.
    • Muista testata koko ajan ohjelmasi toimintaa F5 (debug) tai F6 (build) -komennoilla. HUOM! Jos käännöksessä tulee virheitä, niin Visual Studio ehdottaa, että ajetaanko viimeisin toimiva versio. Mutta tätähän me emme halua, vaan korjata ohjelmamme jotta se toimisi. Joten vastaa No.
    • Tulosta muunnoksen tulos ruudulle.
    • Vinkki: Kun ajat ohjelman, konsoli-ikkuna välähtää ruudulla. Mieti, miksi näin tapahtuu. Jotta näkisit muunnoksen tuloksen, ikkunan on pysyttävä auki riittävän kauan, jotta tulos ehditään lukea. Tähän on kaksi vaihtoehtoa:
      1. Laita BreakPoint pääohjelman viimeisen }-sulkumerkin kohdalla painamalla hiirellä harmaassa palkissa ko rivin kohdalla. Kun ajat ohjelman F5:lla, suoritus pysähtyy tähän ja voit siirtyä konsoli-ikkunaan Alt-Tab näppäimellä. Kun olet tulosta tutkinut, siirry takaisin Visual Studioon ja jatka ajoa F5:lla tai tapa ajo Shift-F5:lla.
      2. Aja ohjelma Ctrl+F5 (=Run Without Debugging).
    • Jatka tehtävä loppuun demon tehtävänannon mukaan.
  4. Tarkastele mitä tiedostoja Visual Studio on luonut hakemistoosi.
    • Suorita tehtävässä 4 tehdyn ohjelman exe-tiedosto komentoriviltä (bin\Debug-kansio)
  5. Lumiukot-esimerkki Visual Studiossa, eli jatka kohdasta Voimia ja sitominen
  6. Muuta Portaat käyttämään kahta aliohjelmaa Demo 3 tehtävä 5 mukaisesti.
  7. Jatka muiden demotehtävien tekemistä.

Huomioita

  • Jos ct-komento ConTextin käynnistämiseksi ei toimi, klikkaa "yhdistä N-asema" -kuvaketta työpöydällä, tai jos pikakuvake puuttuu, liitä N-levy käsin kirjoittamalla komentoriville: net use N: \\eppu.it.jyu.fi\mnt.