wiki:k2014/ohjaukset/ohjaus2
Last modified 4 years ago Last modified on 2014-01-23 22:08:32

Ohjelmointi 1 » Pääteohjaukset » Ohjaus 2

Voit tehdä tämän kertaiset demotehtävät vielä tekstieditorilla, tai sitten Visual Studiossa. Jos haluat jo nyt kokeilla Visual Studion käyttöä, niin lue seuraava ohje. Viimeistään ensi viikolla siirrymme lopullisesti Visual Studioon. Jos kuitenkin haluat vielä jatkaa tavallisella tekstieditorilla, voit siirtyä suoraan tekemään demotehtäviä.

Tee demoista ensimmäisenä tehtävät 4 ja 1.

Visual studion käyttöönotto

Vaikka Visual Studio tekee meidän puolesta monia asioita automaattisesti on kuitenkin tärkeää että ymmärrämme mitä "taustalla" tapahtuu, ja siksi olemme tähän asti operoineet ilman graafista käyttöympäristöä.

Visual Studio on IDE, eli Integrated development environment, suomeksi yleensä vain tylsästi ohjelmointiympäristö. Integrated-sana tarkoittaa lyhyesti sanottuna, että samassa paketissa on monta ohjelmaa, yleensä mm. koodieditori, debuggeri (eli virheenjäljittäjä, johon tutustumme tarkemmin tulevien viikkojen aikana) ja kääntäjä.

(Integroidun) ohjelmointiympäristön käyttämisestä on monia hyötyjä, kuten se, ettemme enää joudu tekemään ohjelman kääntämistä ja kääntämisen jälkeistä suorittamista manuaalisesti. Kuitenkin, jos olisimme suoraan aloittaneet Visual Studiosta, olisi kokonaisuuden ymmärtäminen jäänyt puutteelliseksi.

  1. Käynnistä Visual Studio. Jos et ole aiemmin käynnistänyt Visual Studiota, kysytään käyttöympäristön valintaa. Valitse C# Development Settings ja klikkaa Start Visual Studio. Jos ohjelma kyselee sinulta vielä GhostDoc-asetuksia, voit klikata Skip.
    • Jos kuitenkin vahingossa klikkasit jotain muuta kuin C#:a, niin ei hätää, toimi seuraavasti: 1. Valitse ylhäältä Tools -> Import and Export Settings..., 2. Valitse "Reset all settings", 3. Valitse "Yes, save my current settings" ja paina Next, 4. Valitse haluamasi ympäristö.
  2. Rivinumerot näkyviin. Tools -> Options -> Text Editor -> C# -> Line numbers. Jos haluat niin voit suurentaa tai pienentää myös fonttia Tools -> Options -> Environments -> Fonts and Colors. Tilapäisesti myös Ctrl + hiiren rulla.

Projektin luominen Visual Studiossa

  • File -> New -> Project (tai Ctrl + Shift + N)
  • Valitse projektin tyypiksi Visual C# -> Console Application.
  • Anna projektin nimeksi Muunnoksia,
  • Kirjoita tai selaa (Browse) poluksi C:\MyTemp\OMATUNNUS\ohjaukset\ohjaus2 (tai mikä onkaan oma demohakemistosi). HUOM! Suositellaan aina tekemistä ensin paikalliselle levylle, esim. C:\MyTemp\omatunnus\.... Muista siirtää lopuksi TÄRKEÄT tiedostot U-asemallesi.
  • Klikkaa Create new directory for solution.
  • Anna solutionin nimeksi demo2.
  • Klikkaa Ok.
  • Muuta Solution Explorerissa kooditiedoston Program.cs nimeksi Muunnoksia.cs (Hiiren oikea nimen päällä). Vastaa Yes kun VS kysyy huomioidaanko muutos projektin muissakin tiedostoissa. Nyt luokan nimikin pitäisi olla muuttunut koodissa.
  • Console Application on luonut "vähän turhaan" nimiavaruuden (namespace). Poista rivi jolla lukee namespace ja sitä seuraava aloittava aaltoulku { ja lopusta nimiavaruuden päättävä aaltosulku }.
  • Lisää public -määritys sekä Main-metodin että luokan esittelyyn. Poista myös ylimääräiset using-lauseet. Muutosten jälkeen koodin tulisi näyttää tältä:
    using System;
    
    public class Laskutoimituksia
    {
        public static void Main(string[] args)
        {
        }
    }
    
  • Muotoile sisennykset "kauniiksi" : Edit/Advanced/Format Document (voit vaikka opetella ulkoa tuon pikakomennon Ctrl-E D).
  • Kirjoita luokan dokumentaatiokommentti näppäilemällä luokan esittelyrivin yläpuolelle kolme kauttaviivaa ///. Kirjoita <summary>-tagien väliin selvitys luokan toiminnasta.
  • Kirjoita vastaavasti Main -funktion kommentit.
  • Kirjoita Main-pääohjelman sisään kaksi muuttujaa double paino ja double pituus, ja anna niille jotkin lukuarvot. Voit katsoa apuja luennon mallikoodista.
  • Lisää pääohjelmaan rivi, joka tulostaa painoindeksin näytölle.
  • Laita vielä loppuun (ennen Main-pääohjelman loppusulkua) rivi Console.ReadKey();, niin komentorivi-ikkuna ei sulkeudu heti ohjelman päätyttyä.
  • Dokumentoi luokka ja Main-pääohjelma, eli klikkaa kolme kauttaviivaa luokan ja aliohjelman yläpuolella
  • Kokeile kääntää (F6), tai sitten voit tehdä käännös+ajon yhtä aikaa (F5)
  • HUOM! Jos ajoyrityksessä (painamalla F5) tulee virheitä, niin Visual Studio ehdottaa, että ajetaanko viimeisin toimiva versio. Mutta tätähän me emme halua, vaan korjata ohjelmamme jotta se toimisi. Joten vastaa No.

Huomioita Jypeli-projekteista

Jypeli-projektissa Main-pääohjelma menee Ohjelma.cs-tiedostoon, joten jos copy-pastetat koodin (esimerkiksi demo2/tehtävä4), niin poista Main-pääohjelma Portaat-luokan sisältä.