wiki:k2013/ohjaukset/ohjaus3
Last modified 5 years ago Last modified on 2013-01-31 22:42:19

Pääteohjaukset » Pääteohjaus 3

Nyt siirrymme ConTextista ja komentoriviltä kääntämisestä Visual Studioon. Vaikka Visual Studio tekee meidän puolesta monia asioita automaattisesti on kuitenkin tärkeää että ymmärrämme mitä "taustalla" tapahtuu, ja siksi olemme tähän asti operoineet ilman graafista käyttöympäristöä.

Visual Studio on IDE, eli Integrated development environment, suomeksi yleensä vain tylsästi ohjelmointiympäristö. Integrated-sana tarkoittaa lyhyesti sanottuna, että samassa paketissa on monta ohjelmaa, yleensä mm. koodieditori, debuggeri (eli virheenjäljittäjä, johon tutustumme tarkemmin ensi viikolla) ja kääntäjä.

(Integroidun) ohjelmointiympäristön käyttämisestä on monia hyötyjä, kuten se, ettemme enää joudu tekemään ohjelman kääntämistä ja kääntämisen jälkeistä suorittamista manuaalisesti. Kuitenkin, jos olisimme suoraan aloittaneet Visual Studiosta, olisi kokonaisuuden ymmärtäminen jäänyt puutteelliseksi.

  1. Käynnistä Visual Studio. Jos et ole aiemmin käynnistänyt Visual Studiota, kysytään käyttöympäristön valintaa. Valitse C# Development Settings ja klikkaa Start Visual Studio. Jos ohjelma kyselee sinulta vielä GhostDoc-asetuksia, voit klikata Skip.
    • Jos kuitenkin vahingossa klikkasit jotain muuta kuin C#:a, niin ei hätää, toimi seuraavasti: 1. Valitse ylhäältä Tools -> Import and Export Settings..., 2. Valitse "Reset all settings", 3. Valitse "Yes, save my current settings" ja paina Next, 4. Valitse haluamasi ympäristö.
  2. Rivinumerot näkyviin. Tools -> Options -> Text Editor -> C# -> Line numbers. Jos haluat niin voit suurentaa tai pienentää myös fonttia Tools -> Options -> Environments -> Fonts and Colors. Tilapäisesti myös Ctrl + hiiren rulla.
  3. Ota itsellesi malliksi tiistain luentojen malliohjelma Funktioita.cs (avaa tämä tiedosto vaikka tekstieditoriin niin ei turhaan "häiritse" Visual Studiossa)
  4. Tehdään Demo 3 tehtävä 4 ja sitä varten ensimmäinen projekti (ohjeet alla, voit lisäksi lukea yksityiskohtaisemmat ohjeet projektin luomiseksi).

Projektin luominen Visual Studiossa

  • File -> New -> Project (tai Ctrl + Shift + N)
  • Valitse projektin tyypiksi Visual C# -> Console Application.
  • Anna projektin nimeksi Muunnoksia,
  • Kirjoita tai selaa (Browse) poluksi C:\MyTemp\OMATUNNUS\ohjaukset\ohjaus3 (tai mikä onkaan oma demohakemistosi). HUOM! Suositellaan aina tekemistä ensin paikalliselle levylle, esim. C:\MyTemp\omatunnus\.... Muista siirtää lopuksi TÄRKEÄT tiedostot U-asemallesi.
  • Klikkaa Create new directory for solution.
  • Anna solutionin nimeksi demo3.
  • Klikkaa Ok.
  • Muuta Solution Explorerissa kooditiedoston Program.cs nimeksi Muunnoksia.cs (Hiiren oikea nimen päällä). Vastaa Yes kun VS kysyy huomioidaanko muutos projektin muissakin tiedostoissa. Nyt luokan nimikin pitäisi olla muuttunut koodissa.
  • Console Application on luonut "vähän turhaan" nimiavaruuden (namespace). Poista rivi jolla lukee namespace ja sitä seuraava aloittava aaltoulku { ja lopusta nimiavaruuden päättävä aaltosulku }.
  • Lisää public -määritys sekä Main -metodin että luokan esittelyyn. Poista myös ylimääräiset using -määritykset. Muutosten jälkeen koodin tulisi näyttää tältä:
    using System;
    
    public class Muunnoksia
    {
        public static void Main(string[] args)
        {
        }
    }
    
  • Muotoile sisennykset "kauniiksi" : Edit/Advanced/Format Document (voit vaikka opetella ulkoa tuon pikakomennon Ctrl-E D).
  • Kirjoita luokan dokumentaatiokommentti näppäilemällä luokan esittelyrivin yläpuolelle kolme kauttaviivaa ///. Kirjoita <summary>-tagien väliin selvitys luokan toiminnasta.
  • Kirjoita vastaavasti Main -funktion kommentit.
  • Kirjoita Main-metodin sisään tehtävässä annetut kaksi koodiriviä.
  • Lisää pääohjelmaan rivi, joka tulostaa muunnoksen tuloksen näytölle.
  • Kirjoita tarvittavan aliohjelman esittelyrivi, alku ja loppu sulku {} ja laita aluksi aliohjelman sisällöksi pelkkä return 0;
  • Dokumentoi aliohjelma (vertaa vaikka Funktiot.cs:n BMI-funktioon).
  • Kokeile ajaa (F5)
  • Lisää aliohjelman toiminta oikeaksi.
  • Muista testata koko ajan ohjelmasi toimintaa F5 (debug) tai F6 (build) -komennoilla. HUOM! Jos käännöksessä tulee virheitä, niin Visual Studio ehdottaa, että ajetaanko viimeisin toimiva versio. Mutta tätähän me emme halua, vaan korjata ohjelmamme jotta se toimisi. Joten vastaa No.

Ohjelman pysäyttäminen

Kun ajat ohjelman, konsoli-ikkuna välähtää ruudulla. Jotta näkisit muunnoksen tuloksen, ikkunan on pysyttävä auki riittävän kauan, jotta tulos ehditään lukea. Tähän on kaksi vaihtoehtoa:

  1. Laita keskeytyskohta (breakpoint) pääohjelman viimeisen }-sulkumerkin kohdalle ruudun vasemmassa reunassa painamalla hiirellä harmaassa palkissa ko rivin kohdalla. Kohdalle ilmestyy punainen "stop-merkki". Kun ajat ohjelman, suoritus pysähtyy tähän ja voit siirtyä konsoli-ikkunaan Alt-Tab-näppäinyhdistelmällä. Siirry takaisin Visual Studioon ja jatka ajoa F5:lla tai lopeta ohjelma Shift-F5:lla.
  2. Lisää pääohjelman loppuun ennen loppusulkua koodirivi, joka odottaa näppäimen painamista. Tämä onnistuu kutsumalla aliohjelmaa Console.ReadKey(), joka lukee näppäimistöltä yhden näppäimen painalluksen. Tämän vaihtoehdon huono puoli on se, että tämä rivi ei oikeasti kuulu ohjelmaan ja se pitäisi muistaa poistaa.
  • Jatka tehtävä 4 loppuun demon tehtävänannon mukaan.

Mitä tiedostoa Visual Studio tekee

Tarkastele mitä tiedostoja Visual Studio on luonut hakemistoosi. Suorita tehtävässä 4 tehdyn ohjelman exe-tiedosto komentoriviltä (bin\Debug-kansio)

Lumiukko Visual Studiossa

Tee Lumiukot-esimerkki Visual Studiossa, eli jatka kohdasta Voimia ja sitominen

Portaat

Muuta Portaat käyttämään kahta aliohjelmaa Demo 3 tehtävä 5 mukaisesti.

Jatka muiden demotehtävien tekemistä.

Huomioita

  • Jos npp (Notepad ++) tai ct-komento ConTextin käynnistämiseksi ei toimi, klikkaa "yhdistä N-asema" -kuvaketta työpöydällä.