wiki:VisualStudio
Last modified 14 months ago Last modified on 2016-01-20 13:09:06

Visual Studion käyttö

Katso myös

0. Ensimmäinen käyttökerta

  • Rivinumeroiden käyttöönotto: Tools -> Options -> Text Editor -> C# -> Line Numbers -täppä
  • Ota Error list-ikkuna käyttöön: View -> Error List

1. Solutionit ja projektit

Visual Studiossa on Solutioneja ja projekteja. Yhdessä Solutionissa voi olla monta projektia ja jokaisen projektin täytyy kuulua jonkin Solutioniin. Uuden ohjelman kirjoittaminen alkaa aina projektin perustamisella johonkin Solutioniin, jolloin myös Solution luodaan, ellei sitä ole jo tehty. Hierarkia ei ole kiveen hakattu, mutta tällä kurssilla kätevintä on ehkä tehdä seuraavasti.

  • Luo jokaiselle demokerralle (vastaavasti ohjauskerralle) uusi Solution, eli kun aloitat tekemään ensimmäistä demotehtävää (ohjaustehtävää) niin toimi seuraavasti
    • Klikkaa File -> New project (Ctrl+Shift+N),
    • Valitse projektin tyyppi: Jos teet konsoliohjelmaa niin valitse C#-kohdasta Console Application (tai ConsoleMain jos olet sallaisen asentanut). Jos teet Jypeli-peliä, valitse Jypeli-kohdasta haluamasi projektimalli (esimerkiksi Fysiikkapeli tai PerusPeli).
    • Laita Location-kohtaan demotehtäviesi juuripolku, eli vaikkapa u:\ohjelmointi1\demot tai kotikoneellasi esimerkiksi C:\MyTemp\ohjelmointi\demot. Ei ääkkösiä eikä välilyöntejä kansioiden eikä tiedostojen nimissä.
    • Valitse Solution-valikosta Create new Solution ja paina Create directory for solution (tärkeä)
    • Laita Solution Name kohtaan demoN (N = demokerran numero), esimerkiksi demo3
    • Anna projektille (eli tehtävälle) nimi kohtaan Name (esimerkiksi Lumiukko tai HelloWorld),
    • Nyt sinulle on luotu uusi Solution ja yksi projekti.
  • Kun haluat lisätä demotehtäviä (projekteja) tiettyyn demokertaan (Solutioniin) toimi näin
    • Avaa sen demokerran Solution johon haluat tehtävän lisätä (ellei se ole jo auki Visual Studiossa)
    • Hiiren oikealla Solution Explorerissa solutionin nimen päällä ja sieltä Add/New project
    • Anna projektille nimi, jätä Location ennalleen.

Näin tehtynä kaikki yhden demokerran tehtävät löytyvät "saman katon alta" eli yhden Solutionin kaikki projektit menevät samaan kansioon. Resurssienhallinnassa hakemistopuusi voisi näyttää esimerkiksi tältä

ohj1
 |
 +-demot 
 |  +-demo1
 |  | +-HelloWorld
 |  | '-Lumiukko
 |  | 
 |  '-demo2
 |    +-Lumiukko2
 |    '-LukujenLaskemista
 |
 '-ohjaukset
    +-ohjaus1
    | +-HelloWorld
    | '-Lumiukko
    '-ohjaus2
  • Jos käytät namespacea (esim. Console Application template tekee tämän etkä halua sitä poistaa), niin ole tarkkana että namespacella ja luokalla (class) on eri nimi.

2. Projektien kooditiedostojen sijainti

Kun olet luonut projektin, luodaan sille seuraavanlainen hakemistorakenne (tässä esimerkkinä Lumiukko.

 +-Lumiukko
    +-bin
    +-obj
    +-Properties
    +-Lumiukko.csproj
    '-Lumiukko.cs

Joista bin, obj ja Properties ovat kansioita, Lumiukko.csproj ja Lumiukko.cs ovat tiedostoja.

  • bin-kansioon tulee mm. exe-tiedosto, joka kääntämisen seurauksena syntyy
  • obj-kansio sisältää debuggauksen aikana syntynyttä tietoa
  • Properties-kansiossa on projektin yleisiä tiedostoja, kuten Copyright-merkintöjä yms.

Lumiukko.cs sisältää lähdekoodin, ja se on palautettava tiedosto. Muita tiedostoja ei tarvitse palauttaa, ellei niitä erikseen pyydetä palautettavaksi.

Huom! Jypeli-projektimalleista luoduissa ohjelmissa projektikansion sisään luodaan automaattisesti myös ProjektiContent-kansio, esimerkiksi LumiukkoContent. Visual Studio luo peleissä käytettävälle sisällölle (kuville, videoille, äänille, yms) oman projektinsa.

3. Jypeli-pelien luominen ellei projektimallia ole käytettävissä

Jos työskentelet koneella tai ohjelmistolla missä ei ole Jypeli-projektimalleja (linkki NPO wikiin) käytettävissä, voit silti käyttää Jypeli-kirjastoa. Seuraava ohje on Visual Studio Ultimate 2010:lle. (Muista että XNA Game Studio 4 pitää olla kuitenkin asennettuna.)

  • Tee uusi C# Console Application
  • Mene Solution exploreriin ja klikkaa tekemäsi projektin päällä Add reference
  • Mene Browse-välilehdelle ja hae koneeltasi Jypeli.dll, valitse ja paina OK. Tiedosto ilmestyy References-listaan
  • Ohjelma käynnistyy nyt ensisijaisesti konsoli-ikkunana (ja graafinen ikkuna jää jonnekin "taakse"), eli tarvitaan vielä seuraava muutos. Project -> Properties -> Output type -> Windows Application.